import re
regex = re.compile(r"[^/.]+/(?0)?\.\./")
test_str = ("out/src/../pictures/all/image.jpg\n"
"out/pictures/all/image.jpg\n\n"
"deep/hey there/folder/out/src/../../../pictures/all/image.jpg\n"
"deep/hey there/out/src/../../pictures/all/image.jpg\n"
"deep/hey there/out/../pictures/all/image.jpg\n"
"deep/hey there/pictures/all/image.jpg")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)