#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\$\{.*\#each\s+(.*)\s+in\s+(.*)\s*\}([\w.\s\S]*)\$\{\#endeach\}"
Local $sString = "<script id="name-tmpl" type="text/html" data-source="items">" & @CRLF & _
" <div>" & @CRLF & _
" ${item.name}" & @CRLF & _
" </div>" & @CRLF & _
"</script>"
Local $sSubst = "<%(function(_items){for(var i=0;i<_items.length;i++){var $1=_items[i];%>$3<%}($2))%>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)