re = /\$\{.*\#each\s+(.*)\s+in\s+(.*)\s*\}([\w.\s\S]*)\$\{\#endeach\}/i
str = '<script id="name-tmpl" type="text/html" data-source="items">
<div>
${item.name}
</div>
</script>'
subst = '<%(function(_items){for(var i=0;i<_items.length;i++){var $1=_items[i];%>$3<%}($2))%>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result