import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\{.*\\#each\\s+(.*)\\s+in\\s+(.*)\\s*\\}([\\w.\\s\\S]*)\\$\\{\\#endeach\\}";
final String string = "<script id=\"name-tmpl\" type=\"text/html\" data-source=\"items\">\n"
+ " <div>\n"
+ " ${item.name}\n"
+ " </div>\n"
+ "</script>";
final String subst = "<%(function(_items){for(var i=0;i<_items.length;i++){var $1=_items[i];%>$3<%}($2))%>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}