package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\$\{.*\#each\s+(.*)\s+in\s+(.*)\s*\}([\w.\s\S]*)\$\{\#endeach\}`)
var str = []byte(`<script id="name-tmpl" type="text/html" data-source="items">
<div>
${item.name}
</div>
</script>`)
var substitution = []byte("<%(function(_items){for(var i=0;i<_items.length;i++){var $1=_items[i];%>$3<%}($2))%>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}