use strict;
my $str = '<script id="name-tmpl" type="text/html" data-source="items">
<div>
${item.name}
</div>
</script>';
my $regex = qr/\$\{.*\#each\s+(.*)\s+in\s+(.*)\s*\}([\w.\s\S]*)\$\{\#endeach\}/ip;
my $subst = '<%(function(_items){for(var i=0;i<_items.length;i++){var $1=_items[i];%>$3<%}($2))%>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";