$re = '/\$\{.*\#each\s+(.*)\s+in\s+(.*)\s*\}([\w.\s\S]*)\$\{\#endeach\}/i';
$str = '<script id="name-tmpl" type="text/html" data-source="items">
<div>
${item.name}
</div>
</script>';
$subst = "<%(function(_items){for(var i=0;i<_items.length;i++){var $1=_items[i];%>$3<%}($2))%>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;