// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\$\{.*\#each\s+(.*)\s+in\s+(.*)\s*\}([\w.\s\S]*)\$\{\#endeach\}").unwrap();
let string = "<script id=\"name-tmpl\" type=\"text/html\" data-source=\"items\">
<div>
${item.name}
</div>
</script>";
let substitution = "<%(function(_items){for(var i=0;i<_items.length;i++){var $1=_items[i];%>$3<%}($2))%>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}