using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http[s]{0,1}:\/\/(.*?)(?:[\/?&#]|$)";
string input = @"http://abc.com#
http://abc.com.asdoasd&sds
http://abc.com.co
http://abc.com.co?&xp=wer
http://abc.com.co/p
http://abc.com?p
https://abc.com?p";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}