import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http[s]{0,1}:\\/\\/(.*?)(?:[\\/?&#]|$)";
final String string = "http://abc.com#\n"
+ "http://abc.com.asdoasd&sds\n"
+ "http://abc.com.co\n"
+ "http://abc.com.co?&xp=wer\n"
+ "http://abc.com.co/p\n"
+ "http://abc.com?p\n"
+ "https://abc.com?p";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}