// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^http[s]{0,1}:\/\/(.*?)(?:[\/?&#]|$)").unwrap();
let string = "http://abc.com#
http://abc.com.asdoasd&sds
http://abc.com.co
http://abc.com.co?&xp=wer
http://abc.com.co/p
http://abc.com?p
https://abc.com?p";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}