$re = '/^http[s]{0,1}:\/\/(.*?)(?:[\/?&#]|$)/mi';
$str = 'http://abc.com#
http://abc.com.asdoasd&sds
http://abc.com.co
http://abc.com.co?&xp=wer
http://abc.com.co/p
http://abc.com?p
https://abc.com?p';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);