use strict;
my $str = 'http://abc.com#
http://abc.com.asdoasd&sds
http://abc.com.co
http://abc.com.co?&xp=wer
http://abc.com.co/p
http://abc.com?p
https://abc.com?p';
my $regex = qr/^http[s]{0,1}:\/\/(.*?)(?:[\/?&#]|$)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}