const regex = /^http[s]{0,1}:\/\/(.*?)(?:[\/?&#]|$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http[s]{0,1}:\\\/\\\/(.*?)(?:[\\\/?&#]|$)', 'gmi')
const str = `http://abc.com#
http://abc.com.asdoasd&sds
http://abc.com.co
http://abc.com.co?&xp=wer
http://abc.com.co/p
http://abc.com?p
https://abc.com?p`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}