#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)^.*Your Username:.(.*)(?!.Your Password)$"
Local $sString = "Subscription/Member ID: 1655107153 Your Username: jose1234" & @CRLF & _
"Your Password: jose1234"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)