import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*Your Username:.(.*)(?!.Your Password)$";
final String string = "Subscription/Member ID: 1655107153 Your Username: jose1234\n"
+ "Your Password: jose1234";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}