import re
regex = re.compile(r"^.*Your Username:.(.*)(?!.Your Password)$", flags=re.DOTALL)
test_str = ("Subscription/Member ID: 1655107153 Your Username: jose1234\n"
"Your Password: jose1234")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)