re = /^.*Your Username:.(.*)(?!.Your Password)$/
str = 'Subscription/Member ID: 1655107153 Your Username: jose1234
Your Password: jose1234'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result