#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\[.*?\])"
Local $sString = "here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)