re = /(\[.*?\])/
str = 'here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result