$re = '/(\[.*?\])/';
$str = 'here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;