import Foundation
let pattern = #"(\[.*?\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)