package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[.*?\])`)
var str = `here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}