using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[.*?\])";
string substitution = @"";
string input = @"here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}