use strict;
my $str = 'here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here';
my $regex = qr/(\[.*?\])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";