const regex = /(\[.*?\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[.*?\\])', 'g')
const str = `here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);