#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^?&=]+=(?:&|$)|&[^?&=]+=(?=&|$)"
Local $sString = "http://localhost/wm/frontend/www/?test-123=&lol=1&boo=2&empty.var="
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)