using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^?&=]+=(?:&|$)|&[^?&=]+=(?=&|$)";
string substitution = @"";
string input = @"http://localhost/wm/frontend/www/?test-123=&lol=1&boo=2&empty.var=";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}