re = /[^?&=]+=(?:&|$)|&[^?&=]+=(?=&|$)/
str = 'http://localhost/wm/frontend/www/?test-123=&lol=1&boo=2&empty.var='
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result