use strict;
my $str = 'http://localhost/wm/frontend/www/?test-123=&lol=1&boo=2&empty.var=';
my $regex = qr/[^?&=]+=(?:&|$)|&[^?&=]+=(?=&|$)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";