$re = '/[^?&=]+=(?:&|$)|&[^?&=]+=(?=&|$)/';
$str = 'http://localhost/wm/frontend/www/?test-123=&lol=1&boo=2&empty.var=';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;