import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^?&=]+=(?:&|$)|&[^?&=]+=(?=&|$)";
final String string = "http://localhost/wm/frontend/www/?test-123=&lol=1&boo=2&empty.var=";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}