import re
regex = re.compile(r"[^?&=]+=(?:&|$)|&[^?&=]+=(?=&|$)")
test_str = "http://localhost/wm/frontend/www/?test-123=&lol=1&boo=2&empty.var="
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)