const regex = /[^?&=]+=(?:&|$)|&[^?&=]+=(?=&|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^?&=]+=(?:&|$)|&[^?&=]+=(?=&|$)', 'g')
const str = `http://localhost/wm/frontend/www/?test-123=&lol=1&boo=2&empty.var=`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);