using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"digraph Checker\s+{((?:[^{]*{[^}]*})*[^}]*)}";
string input = @"{ /*uninterested in this*/
""
digraph Checker
{
/*bunch of stuff*/
{
/*bunch of stuff*/
}
{
/*bunch of stuff*/
}
{
/*bunch of stuff*/
}
/*bunch of stuff*/
} //first most curly brace ends, would want the regex to filter out till here, incl. the braces
""
}";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}