import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "digraph Checker\\s+\\{((?:[^\\{]*\\{[^\\}]*\\})*[^\\}]*)\\}";
final String string = "{ /*uninterested in this*/ \n"
+ "\"\n"
+ "digraph Checker \n"
+ "{ \n"
+ "/*bunch of stuff*/\n"
+ "{\n"
+ "/*bunch of stuff*/\n"
+ "}\n"
+ "{\n"
+ "/*bunch of stuff*/\n"
+ "}\n"
+ "{\n"
+ "/*bunch of stuff*/\n"
+ "}\n"
+ "/*bunch of stuff*/\n"
+ "} //first most curly brace ends, would want the regex to filter out till here, incl. the braces\n"
+ "\"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}