import re
regex = re.compile(r"digraph Checker\s+{((?:[^{]*{[^}]*})*[^}]*)}", flags=re.IGNORECASE)
test_str = ("{ /*uninterested in this*/ \n"
"\"\n"
"digraph Checker \n"
"{ \n"
"/*bunch of stuff*/\n"
"{\n"
"/*bunch of stuff*/\n"
"}\n"
"{\n"
"/*bunch of stuff*/\n"
"}\n"
"{\n"
"/*bunch of stuff*/\n"
"}\n"
"/*bunch of stuff*/\n"
"} //first most curly brace ends, would want the regex to filter out till here, incl. the braces\n"
"\"\n"
"}")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")