$re = '/digraph Checker\s+{((?:[^{]*{[^}]*})*[^}]*)}/i';
$str = '{ /*uninterested in this*/
"
digraph Checker
{
/*bunch of stuff*/
{
/*bunch of stuff*/
}
{
/*bunch of stuff*/
}
{
/*bunch of stuff*/
}
/*bunch of stuff*/
} //first most curly brace ends, would want the regex to filter out till here, incl. the braces
"
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);