const regex = /digraph Checker\s+{((?:[^{]*{[^}]*})*[^}]*)}/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('digraph Checker\\s+{((?:[^{]*{[^}]*})*[^}]*)}', 'i')
const str = `{ /*uninterested in this*/
"
digraph Checker
{
/*bunch of stuff*/
{
/*bunch of stuff*/
}
{
/*bunch of stuff*/
}
{
/*bunch of stuff*/
}
/*bunch of stuff*/
} //first most curly brace ends, would want the regex to filter out till here, incl. the braces
"
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}