import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?:([a-z0-9-]+|\\*)\\.)?([a-z0-9-]{1,61})\\.([a-z0-9]{2,7})$";
final String string = "website.com\n"
+ "www.website.com\n"
+ "*.website.com\n"
+ "*x.website.com\n"
+ "x*.website.com\n"
+ "**.website.com\n"
+ "website.aaaaaaaaaaa\n"
+ "totally-not.a-sketchy.site\n"
+ "bad_website.com\n"
+ "web-site.net";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}