import re
regex = re.compile(r"(?i)^(?:([a-z0-9-]+|\*)\.)?([a-z0-9-]{1,61})\.([a-z0-9]{2,7})$", flags=re.MULTILINE)
test_str = ("website.com\n"
"www.website.com\n"
"*.website.com\n"
"*x.website.com\n"
"x*.website.com\n"
"**.website.com\n"
"website.aaaaaaaaaaa\n"
"totally-not.a-sketchy.site\n"
"bad_website.com\n"
"web-site.net")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")