#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "0(?=00)|(?<=00)0|(?<=0)0(?=0)"
Local $sString = "1001000001" & @CRLF & _
"1001" & @CRLF & _
"10001" & @CRLF & _
""
Local $sSubst = "1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)