const regex = /0(?=00)|(?<=00)0|(?<=0)0(?=0)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0(?=00)|(?<=00)0|(?<=0)0(?=0)', 'g')
const str = `1001000001
1001
10001
`;
const subst = `1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);