$re = '/0(?=00)|(?<=00)0|(?<=0)0(?=0)/';
$str = '1001000001
1001
10001
';
$subst = "1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;