import Foundation
let pattern = #"0(?=00)|(?<=00)0|(?<=0)0(?=0)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1001000001
1001
10001
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)