import re
regex = re.compile(r"0(?=00)|(?<=00)0|(?<=0)0(?=0)")
test_str = ("1001000001\n"
"1001\n"
"10001\n")
subst = "1"
result = regex.sub(subst, test_str)
if result:
print(result)