re = /0(?=00)|(?<=00)0|(?<=0)0(?=0)/
str = '1001000001
1001
10001
'
subst = '1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result