#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)"
Local $sString = " 1 MASS" & @CRLF & _
" 2 BLOCKCOUNT" & @CRLF & _
" 3 SECTOR" & @CRLF & _
" 4 SYSTEM" & @CRLF & _
"" & @CRLF & _
"SECOND DISPLAY BLOCK REGEX COMMAND" & @CRLF & _
"" & @CRLF & _
"[REPLACEFIRST]^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)[WITH]#$3# $5" & @CRLF & _
"$6"
Local $sSubst = "#$3# $5\n$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)