package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)`)
var str = ` 1 MASS
2 BLOCKCOUNT
3 SECTOR
4 SYSTEM
SECOND DISPLAY BLOCK REGEX COMMAND
[REPLACEFIRST]^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)[WITH]#$3# $5
$6`
var substitution = "#$3# $5\n$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}