using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)";
string substitution = @"#$3# $5\n$6";
string input = @" 1 MASS
2 BLOCKCOUNT
3 SECTOR
4 SYSTEM
SECOND DISPLAY BLOCK REGEX COMMAND
[REPLACEFIRST]^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)[WITH]#$3# $5
$6";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}